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[bookmark: _Toc241309855]Introduction
SSL (Secure Sockets Layer) is a commonly used protocol for managing the security of a message transmission on the Internet. Galileo SSL enables agencies to use their existing computers and print servers to access the Apollo® and Galileo® Computer Reservation Systems (CRS) over the public Internet via an encrypted, secured connection.
[bookmark: _Toc333998181][bookmark: _Toc147566989][bookmark: _Toc165270993][bookmark: _Toc194250503][bookmark: _Ref203969564][bookmark: _Ref203969568][bookmark: _Toc241309856]Supported Products
SSL is implemented for agencies running these products:
Viewpoint 3.0/Focalpoint™ 3.5 and later.
Galileo Desktop 1.01 and later.
Galileo Print ManagerTM (GPM) 4.0 and later.
Note:	Earlier versions of GPM do not have the option to Always Connect on
		Startup, which is required for Galileo SSL.
Galileo Integrated Data Source (GIDS)
PM Browser.
XML SelectTM
Products that use a TN3270 emulator for connectivity.
Products that use a proxy server for connectivity.
No changes for SSL will be made for current internet-dependent products and services, such as:
Galileo Web Services (GWS)™
Galileo Flight Integrator (GFI)™
Galileo Desktop Internet Access (GDIA)
[bookmark: _Toc241309857]Minimum Software Requirements
The following requirements are needed for the SSL installation:
A supported product.
Internet access.
Allow SSL service on port 443 through Firewall or other customer infrastructure.
Set idle timeouts on port 443 connections at 3600 seconds or higher.
If using an HTTP proxy, ensure the proxy idle timeout on port 443 is set to 3600 seconds or higher.
Windows 2000 Professional®, Windows XP® (all versions) or Windows Vista® (all versions).
Note: It is possible to support a Legacy OS in Gateway Mode.
Microsoft .NET Framework® version 2.0 (x86) or later needs to be installed. If .NET Framework is not present, the installation process automatically downloads this software from Microsoft and completes this portion of the installation.
Microsoft Installer 3.1 v2 (KB893803)
If Microsoft XP is installed, Microsoft Installer 3.1 v2 or later must be installed.
Notes: 
The installer must have Administrative rights.
Install SSL connection under the supervision of someone with a working knowledge of your office hardware.
ISP must provide minimum bandwidth as legacy leased-line providers. Ensure you monitor ISP connection utilization and increase the bandwidth when utilization grows close to saturation. Most agencies discover that the bandwidth to support GDS access is extremely low.
As a precaution all Client IDs should be captured before installing a new version of the SSL Client. See the SSL Versioning Guide view instructions on how to determine the Client ID.
[bookmark: _Toc241309858]
Installing Galileo SSL
The instructions for installing and configuring Galileo SSL can vary not only by supported product, but also by the type of environment. Therefore, the following steps should be followed before installing Galileo SSL and configuring your supported products.
Review this section for installation pre-requisites and the Basic Installation information.
Review the Installation Environments for Galileo SSL section on page 10 and install Galileo SSL based on the selected environment.
Go to Configuring Galileo SSL for Supported Products on page 18 for instructions on configuring the supported products that will use the Galileo SSL connection.
Note:	Configuration requirements for supported products may vary depending on the environment in which they are installed. Be sure to confirm the appropriate environment before proceeding with the configuration instructions.
[bookmark: _Toc241309859]Before Installing Galileo SSL
Before installing the Galileo SSL Client:
Ensure that one of the supported products is installed. See page Supported Products on page 5 for a list of products that use Galileo SSL.
Close any supported applications before installation. 
If running one of the applications, a message similar to the following displays:

Close the associated application and click Yes.
If Galileo SSL Client was previously installed, the installation prompts you to uninstall any previous Galileo SSL Client versions. You do not need to manually uninstall previous installations. The following dialog box displays:

Click Yes. A Progress dialog displays.

When installing the SSL in a Server Mode environment, allow proper Firewall and Virus software exceptions to allow proper UDP and TCP/IP network protocol exceptions required for applicable applications. This applies to Firewall and Virus software running on the SSL server and down-stream workstations connecting through the server. 
Please see the Firewall Specifications documentation for specific application.
Note:	If you install the SSL client, create new connection profiles, then uninstall or upgrade the SSL client, you will lose the connection profiles. 
To maintain your connection profiles, manually add the connection profiles, and then install the SSL Client.
[bookmark: _Ref204481361][bookmark: _Ref204481371][bookmark: _Toc241309860]Standard Galileo SSL Installation
The standard Galileo SSL installation applies to installations for all supported products, unless otherwise noted. 
Note:	Be sure to review the Installation Environments for Galileo SSL on page 10 BEFORE installing Galileo SSL. This section provides details for installing Galileo SSL on single machines or various types of networked environments.
Note:	For Silent Installation options see the Silent Installation section below these instructions.
Close any supported products.
Launch the Galileo SSL installation. The method of delivery for this installation may vary by region; the installation location and other details are provided by your Galileo representative. 
However, the main method of delivery is:
http://support.travelport.com/SGC/APS/softlib/GalileoDesktopSSL.htm. Complete the associated form and click Submit.
Note: The installation checks for the presence of Microsoft.NET version 2.0. If the correct version is already installed, the installation will continue. If Microsoft.NET version 2.0 is not found the download starts automatically. The download is approx 23 MB. If installing Microsoft .NET 2.0:
After the Microsoft .NET 2.0 download, if you are prompted with a security message to run or not run, click Run.
Follow the Microsoft.NET install prompts to install. After the install the SSL software installation automatically continues.
The Welcome window displays.

Click Next to display the Terms and Conditions window.
Click the radio button I acknowledge that I have read and agree to the terms and conditions. Click Next to display the Finish Screen.

Click Finish.
After installing Galileo SSL, go to Configuring Galileo SSL for Supported Products on page 18 for instructions on configuring the supported products that will use the Galileo SSL connection.
[bookmark: _Toc241309861]
Silent Installation
If the installation package is an accessible .exe file, an option exists for “silent” install, and no further installation procedures are required. To set the application for Silent Install:
Close any supported products.
Open a command window and navigate to the SSL installation file (.exe) location.
Type the name of the install executable followed by the parameters –s –a –s.. For example, GalileoSSLClient_v01.00.0013.exe -s -a -s
The first parameter ‘s’ specifies that the package for the web extraction is silent.
The second parameter ‘a’ specifies to start setup.exe. 
The third parameter ‘s’ specifies the type of install the setup should run: 's' is silent install.

[bookmark: _Ref204481007][bookmark: _Ref204481009][bookmark: _Toc241309862]Installation Environments for Galileo SSL
SSL can be installed in a variety of environments. The installation type for your agency depends on the way the network is configured, and the specific environment setup. The four most common environments are:
Typical Agency Workstation
Gateway Mode for Citrix Load Balanced (Cluster) or MTS
Stand Alone Citrix or MTS
Agency Gateway Mode for Legacy OS environments
Each environment is described in the related section. After installing Galileo SSL, see Configuring Galileo SSL for Supported Products on page 18 to configure your associated supported products.
[bookmark: _Toc241309863]Typical Agency Workstation
In the Typical Workstation environment, supported products are installed separately on each agency workstation. Therefore, the Galileo SSL Client must also be installed on each agency workstation.
[bookmark: _Toc241309864]Environment Diagram
The following diagram shows the Typical Workstation environment after the Galileo SSL Client is installed.

The Galileo SSL Client is installed on each workstation to route traffic via port 443.
Client launches the supported product, such as Galileo Desktop or Focalpoint.
Data flows to a shared ISP router, which routes all traffic to Travelport’s SSL environment.
Note:	The DNS/VIP numbers depend on location. See Appendix B: DNS/VIP Addresses on page 38 to determine the correct numbers for your location.
[bookmark: _Toc241309865]Installing Galileo SSL
To install SSL in a Typical Agency Workstation environment:
Use the Standard Galileo SSL Installation on page 8. Galileo SSL must be installed separately on each workstation.
Verify that Galileo SSL is installed on the workstation.
From the Start menu, select the Control Panel.
Double-click Add or Remove Programs to display the Add or Remove Programs dialog box.
If Galileo SSL has installed successfully, the currently installed programs list displays Galileo SSL.
After installation, refer to Configuring Galileo SSL for Supported Products on page 18 to determine additional configuration requirements for your supported products.
[bookmark: _Toc241309866]Gateway Mode for a Citrix Load-Balanced (Cluster) or MTS Environment
In a load-balanced Citrix or MTS environment in which the supported products are installed on servers, the Galileo SSL Client is installed on the SSL Gateway machine.
[bookmark: _Toc241309867]Environment Diagram

Client launches Citrix or Microsoft Terminal Server (MTS) with an Integrated Connection Agent (ICA) or Web Client.
On a load-balanced farm, the load-balancing software connects to the least-utilized server.
The server then starts an instance of the supported software. 
When the supported software is launched, it searches for the configuration file for the IPCS fixed (static) IP address of the SSL Gateway. 
Each instance of the supported software must have the IPCS configured for the SSL Gateway’s fixed IP.
The SSL Client must have a fixed IP address or, for advanced users, a DNS name.
The SSL Gateway provides a path to authentication, and a secure encrypted shared connection to Travelport’s SSL environment.
Note:	The DNS/VIP numbers depend on location. See Appendix B: DNS/VIP Addresses on page 38 to determine the correct numbers for your location.
[bookmark: _Toc241309868]
Installing Galileo SSL
To install SSL in Gateway Mode for a Citrix Load Balanced (Cluster) or MTS:
Install SSL on the Gateway machine using the Standard Galileo SSL Installation instructions on page 8.
Open the configuration file SSLClientService.exe.config using Notepad.
Add the following line to the <appSettings> section for the SSL Gateway:
<add key="Server Mode" value="enabled" />
After installation, refer to Configuring Galileo SSL for Supported Products on page 18 to determine additional configuration requirements for your supported products.
[bookmark: _Toc241309869]
Stand-Alone Citrix or MTS
[bookmark: _Toc241309870]Environment Diagram


Client launches Independent Computing Architecture (ICA) to a single Citrix or MTS server.
The MTS or Citrix server starts an instance of the supported software.
When the supported software is launched, it uses the loopback address to authenticate via the SSL Loopback Tunnel.
The SSL client provides authentication, secure encrypted shared connection to Travelport’s SSL environment.
Note:	The DNS/VIP numbers depend on location. See Appendix B: DNS/VIP Addresses on page 38 to determine the correct numbers for your location.
[bookmark: _Toc241309871]
Installing Galileo SSL
To install SSL in a stand-alone Citrix or Microsoft Terminal Server setup:
Install SSL on the stand-alone or MTS server using the Standard Galileo SSL Installation instructions on page 8.
Verify that SSL is installed and running by initiating the Task Manager and finding the entry SSLClientService.exe
After installation, refer to Configuring Galileo SSL for Supported Products on page 18 to determine additional configuration requirements for your supported products.
[bookmark: _Toc241309872]
Agency Gateway Mode for Legacy OS Environments
[bookmark: _Toc241309873]Environment Diagram

Client launches supported products, which target SSL Gateway’s Fixed IP for IPCS.
The SSL Gateway provides authentication path, secure encrypted shared connection to Travelport’s SSL environment.
Note:	The DNS/VIP numbers depend on location. See Appendix B: DNS/VIP Addresses on page 38 to determine the correct numbers for your location.
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Installing Galileo SSL
To install SSL in Agency Gateway Mode in a Legacy OS (Windows 98, NT 4.0, etc.) setup:
Install SSL on the machine designated as the SSL Gateway using the Standard Galileo SSL Installation instructions on page 8.
If the supported application is running on the Gateway, modify the IPCS on each Legacy OS machine
From the Control Panel, double-click the Galileo TCP/IP icon to display the Host/Galileo Desktop TCP/IP Configuration dialog box.

Select the Default connection and click Edit to display the Connection dialog box.

Modify the Primary and Secondary IPCS Address to the fixed IP of the SSL Gateway.
Note:	Advanced Users can select Use Domain Name Services (DNS) to choose to use the DNS name from the local DNS server.
Click OK.
After installation, refer to Configuring Galileo SSL for Supported Products on page 18 to determine additional configuration requirements for your supported products.
[bookmark: _Ref204402762][bookmark: _Toc241309875]Configuring Galileo SSL for Supported Products
After you have installed Galileo SSL for the appropriate installation environment, you must configure your supported products to use the Galileo SSL connection.
Important!:	Configuration requirements for a supported product may vary depending on the environment in which it is installed. Be sure to confirm the appropriate environment before proceeding with the configuration instructions.
[bookmark: _Toc241309876]Configuring Galileo SSL for Galileo Desktop and Galileo Print Manager (GPM)
The configuration instructions for Galileo Desktop vary by environment; follow the instructions for your environment. 
Use of Galileo Print Manager (GPM) is optional; however, please note that configuration instructions can vary depending on whether GPM is installed. 
[bookmark: _Toc241309877]Configuring Galileo Desktop and GPM in a Typical Agency Workstation Environment
These instructions support configuring SSL on Galileo Desktop 1.01 and (optionally) Galileo Print Manager 4.0 or later. 
Note: The configuration instructions are different depending on whether Galileo Print Manager is installed.
Configuring Galileo Desktop for Galileo SSL in a Typical Agency Workstation Environment
After the Galileo SSL installation is completed, the installation automatically changes the Primary and Secondary IPCS Addresses for all Client IDs to use 127.0.0.1 for Galileo SSL access. At the time of the installation, all present Client IDs are updated.
Note:	If you use multiple Client IDs and traditional land-line access, the addresses must be manually configured back to the original addresses. For example: 57.8.81.13 and 57.8.81.113.
To configure Galileo Desktop for Galileo SSL:
Close Galileo Desktop.
From the Start menu, select the Control Panel.
Double-click the Galileo TCP/IP icon to display the Host – Focalpoint TCP/IP Configuration dialog box.

Select your connection and click Edit to display the Client Identifier dialog box. 

In Client Identifier, verify that the Client ID is correct.

Confirm that Use Fixed Configuration Server Addresses is selected.
Confirm that the Primary Address and Alternate Address is 127.0.0.1.
Note:	If you use multiple Client IDs and traditional land-line access, the addresses must be manually configured back to the original addresses. For example: 57.8.81.13 and 57.8.81.113.
Select Force Download.
Click OK.
Note:	Advanced Users Only: In Gateway mode, you may want to select Use Domain Name Services (DNS). 
This would be the DNS Host Name of the Gateway mode server configured on your local network.

Configuring Galileo Print Manager (GPM) for Galileo SSL in a Typical Agency Workstation Environment.
If Galileo Print Manager is installed on the workstation, the configuration address that was updated for Galileo Desktop in the previous section is also updated automatically.
To configure GPM for Galileo SSL:
From the Windows Start menu, select Programs > Galileo Print Manager > Print Manager to display the Galileo Print Manager dialog box.
Click the Configuration Server tab.

In Client Identifier, verify that the Client ID is correct.
Confirm that Use Fixed Configuration Server Addresses is selected.
Confirm that the Primary Address and Alternate Address is 127.0.0.1.
Note:	If you use multiple Client IDs and traditional land-line access, the addresses must be manually configured back to the original addresses. For example: 57.8.81.13 and 57.8.81.113.  
Click Apply.
From the File, select Save.
GPM automatically wakes up because it is configured to Connect on Startup. After GPM connected, it always stays connected. To manually set this option, from the Tools menu, select Connect On Startup.

Note:	If you are running downline in Gateway mode, you can add the IP address of each GPM server in the configuration file. See the GPM section in the table in Appendix A.

[bookmark: _Toc241309878]
Configuring Galileo Desktop in Gateway Mode for a Citrix Load-Balanced (Cluster) or MTS Environment
To configure Galileo Desktop, Modify each Citrix supported application configuration file to reflect the fixed IP of the SSL Gateway.
Stop the Galileo SSL Service:
Right-click My Computer and choose Manage to open to Computer Management dialog box.
Open Services and Applications > Services.
Select the Galileo SSL Service and click STOP.
Keep this dialog box open to restart the service.
Navigate to the Galileo Desktop Users directory, which is typically in a \MACHINE folder.
Right-click dat32com.ini and choose Open With > Choose Program > Notepad.
Find the following text in the configuration file – there are two instances:
IPCName=
PrimaryIPCS=###.###.###.###
SecondaryIPCS=###.###.###.###
Modify the Primary and Secondary IPCS to reflect the fixed IP address of the SSL Gateway.
Choose File > Save.
Restart the Galileo SSL Service:
Select the Galileo SSL Service in the Computer Management dialog box and click START.
Close the Computer Management dialog box.

[bookmark: _Toc241309879]
Configuring Galileo Desktop in a Stand-Alone Citrix or MTS Environment
To configure Galileo Desktop in a Stand-Alone Citrix or Microsoft Terminal Server environment: 
Stop the Galileo SSL Service:
Right-click My Computer and choose Manage to open to Computer Management dialog box.
Open Services and Applications > Services.
Select the Galileo SSL Service and click STOP.
Keep this dialog box open to restart the service.
Navigate to each \(Users)\(Remote Users Home Directory).
Right-click dat32com.ini and choose Open With > Choose Program > Notepad.
Find the following text in the configuration file – there are two instances:
IPCName=
PrimaryIPCS=###.###.###.###
SecondaryIPCS=###.###.###.###
Modify the Primary and Secondary address to reflect the loopback IP address 127.0.0.1
Choose File > Save.
Restart the Galileo SSL Service:
Select the Galileo SSL Service in the Computer Management dialog box and click START.
Close the Computer Management dialog box.

[bookmark: _Toc241309880]
Configuring Viewpoint 3.0/Focalpoint 3.5 and Galileo Print Manager for Galileo SSL
The configuration instructions for Viewpoint/Focalpoint vary by environment; follow the instructions for your environment. 
Use of Galileo Print Manager (GPM) is optional; however, please note that configuration instructions can vary depending on whether GPM is installed. 
[bookmark: _Toc241309881]Configuring Viewpoint 3.0/Focalpoint 3.5 and Galileo Print Manager in a Typical Workstation Environment
These instructions support installing SSL on a Viewpoint 3.0/Focalpoint 3.5 Workstation and (optionally) configuring Galileo Print Manager 4.0 or later. Please note that the configuration instructions are different depending on whether Galileo Print Manager is installed.
Installing Galileo SSL on a Viewpoint 3.0/Focalpoint 3.5 Workstation
To configure Viewpoint 3.0/Focalpoint 3.5 after Galileo SSL is installed:
Verify that Galileo SSL is installed.
Launch Focalpoint. The Focalpoint Configuration Download Status displays.

Confirm that the (loopback) request downloaded from 127.0.0.1 port 5067.
Confirm that the process completed successfully, with no Error 56 or other errors.
After the process completes, click OK to close the Focalpoint Configuration Download Status.
Close Focalpoint.
Modify the Galileo TCP/IP configuration.
From the Start menu, select the Control Panel.
Double-click the Galileo TCP/IP icon to display the Host – Focalpoint TCP/IP Configuration dialog box.

Select your connection and click Edit to display the Client Identifier dialog box. 

In Client Identifier, verify that the Client ID is correct.
Confirm that Use Fixed Configuration Server Addresses is selected.
Change the Primary Address and Alternate Address to 127.0.0.1.
Select Force Download.
Click OK.

Configuring Galileo Print Manager (GPM) for Galileo SSL
If Galileo Print Manager is installed on the workstation, the configuration address that was updated for Viewpoint/Focalpoint in the previous section is also updated automatically.
To configure GPM for Galileo SSL after Galileo SSL is installed:
Close Galileo Print Manager.
From the Windows Start menu, select Programs > Galileo Print Manager > Print Manager to display the Galileo Print Manager dialog box.
Click the Configuration Server tab.

In Client Identifier, verify that the Client ID is correct.
Confirm that Use Fixed Configuration Server Addresses is selected.
Confirm that the Primary Address and Alternate Address is 127.0.0.1.
Note:	If you use multiple Client IDs and traditional land-line access, the addresses must be manually configured back to the original addresses. For example: 57.8.81.13 and 57.8.81.113.  
Click Apply.
Choose File > Save.
GPM automatically wakes up because it is configured to Connect on Startup. After GPM connected, it always stays connected. To manually set this option, from the Tools menu, select Connect On Startup.

Note: If GPM is configured downline of the Gateway, click Apply to manually request the download configuration. The message “Requesting Download” displays.

[bookmark: _Toc241309882]
Configuring Viewpoint 3.0/Focalpoint 3.5 in a Stand-Alone Citrix or MTS Environment
To configure all Focalpoint clients, modify the loopback address (127.0.0.1) in each User account in the\(Users)\(Remote Users Home Directory) directory. In each Focalpoint Users folder:
Stop the Galileo SSL Service:
Right-click My Computer and choose Manage to open to Computer Management dialog box.
Open Services and Applications > Services.
Select the Galileo SSL Service and click STOP.
Keep this dialog box open to restart the service.
Right-click fptcd.ini and choose Open With > Choose Program > Notepad.
Find the following text in the configuration file:
[Configuration Server Address] competent 
Primary Address=###.###.###.###
Secondary Address=###.###.###.###
Modify the Primary and Secondary address to reflect the loopback IP address 127.0.0.1
Navigate to each \(Users)\(Remote Users Home Directory).
Right-click dat32com.ini and choose Open With > Choose Program > Notepad.
Find the following text in the configuration file – there are two instances:
IPCName=
PrimaryIPCS=###.###.###.###
SecondaryIPCS=###.###.###.###
Modify the Primary and Secondary address to reflect the loopback IP address 127.0.0.1
Choose File > Save.
Restart the Galileo SSL Service:
Select the Galileo SSL Service in the Computer Management dialog box and click START.
Close the Computer Management dialog box.
[bookmark: _Toc241309883]
Configuring Viewpoint 3.0/Focalpoint 3.5 in Gateway Mode for a Citrix Load-Balanced (Cluster) or MTS Environment
To configure Viewpoint 3.0/Focalpoint 3.5, or later, in Gateway Mode for a Citrix Load-Balanced (Cluster) or MTS Environment, modify each Citrix-supported application configuration file to reflect the fixed IP of the SSL Gateway:
Stop the Galileo SSL Service:
Right-click My Computer and choose Manage.
Open Services and Applications > Services.
Select the Galileo SSL Service and click STOP.
Navigate to the Focalpoint Users directory, which is typically in the \MACHINE folder.
Right-click fptcd.ini and select Open With > Choose Program > Notepad.
Find the following text in the configuration file:
[Configuration Server Address]
Primary Address=###.###.###.###
Secondary Address=###.###.###.###
Modify the Primary and Secondary address to reflect the fixed IP address of the SSL Gateway.
Choose File > Save.
Restart the Galileo SSL Service:
Select the Galileo SSL Service in the Computer Management dialog box and click START.
Close the Computer Management dialog box.
[bookmark: _Toc241309884]
Configuring GIDS for Galileo SSL
These configuration instructions apply to GIDS implementations in all environments.
Note:	If your GIDS implementation uses more than one queue, contact your Galileo support person.
To configure GIDS for Galileo SSL:
Stop the Galileo SSL Service:
Right-click My Computer and choose Manage.
Open Services and Applications > Services.
Select the Galileo SSL Service and click STOP.
Install Galileo SSL on the machine that runs the GIDS Client Adapter.
Modify the SSLClientService.exe.config file.
Navigate to the Galileo SSL installation folder. 
For example: c:\Program Files\Galileo\SSL.
Right-click the SSLClientService.exe.config file and select Open With.
Select Notepad to display SSLClientService.exe.config in Notepad.
Add the following lines with the GIDS information, under the <appSettings> section if you are installing GIDS after previously installing the SSL Client:
<add key="GIDS Queuename Override" value="7G561G3381" />
Save and close SSLClientService.exe.config.
If running more than one client against the same GIDS queuename, see the following Multiple Clients section.
Open the Galileo IDS Configuration adapter utility.
In the GIDS Application Properties dialog box, change the MQ Host Name destination to 127.0.0.1.
Click Apply.
Restart the Galileo SSL Service:
Select the Galileo SSL Service in the Computer Management dialog box and click START.
Close the Computer Management dialog box.
[bookmark: _Toc241309885]Multiple Clients
If running more than one client against the same GIDS queuename, you must have a unique ID for each client.  The help desk can assist in getting these added to the SSL database. The Unique ID can be an underscore for each queuename. 
For example:
Before:
<add key="GIDS Queuename Override" value="7G561G3381" />
After: (server 1)
<add key="GIDS Queuename Override" value="7G561G3381_1" />
After: (server 2)
<add key="GIDS Queuename Override" value="7G561G3381_2" />
After: (server 3)
<add key="GIDS Queuename Override" value="7G561G3381_3" />

[bookmark: _Toc241309886]
Configuring a TN3270 Emulator for Galileo SSL
These configuration instructions apply to TN3270 Emulator implementations in all environments. To install and configure SSL on a machine that uses a TN3270 emulator to connect:
Install SSL. Use the same installation instructions as specified for Focalpoint 3.5.
Launch the TN3270 emulator.
Navigate to the session configuration options.
Navigate to host IP Address field and add or replace the host IP with the loopback address (127.0.0.1), and port 5023 to route traffic to the Galileo TN3270 Gateway.
Your application settings may vary from the following example:


[bookmark: _Toc241309887]
Configuring XML Select for Galileo SSL
These configuration instructions apply to XML Select implementations in all environments. When installing the Galileo SSL Client in an XML Select environment, the HCM Manager is automatically configured with the loopback settings. 
To install Galileo SSL in an XML Select environment:
Launch the installation.
The installation checks for the presence of Microsoft.NET version 2.0. If already installed, the SSL installation continues.
If Microsoft.NET version 2.0 is not found the download starts automatically. The download is approx 23 MB.
After the download if prompted with a security message to run or not run, click Run.
Follow the Microsoft.NET install prompts to install.
After the .NET install, the SSL software installation automatically continues.
The Welcome Screen displays.
Click Next.
The Terms and Conditions Screen displays.
Click Yes to accept.
The Finish Screen displays.
Click Finish.

Verify the Primary IPCS to the loopback address (127.0.0.1):
Choose Start > Programs > XML Select > HCM Manager Console.
The HCM Manager Console for should look similar to this, with the Primary IPCS configured to the loopback address 127.0.0.1 and Port 5067.


To manually verify this, select the HCM Name and click the Edit  button.
Click the Connection tab. The Edit HCM dialog box should look similar to the following:
 
NOTE: SSL has not been tested on the Galileo Test and Copy system.
[bookmark: _Toc241309888]
Configuring Customer Proxy Servers for Galileo SSL
These configuration instructions apply to Customer proxy servers in a Typical Agency Workstation environment only.
This section describes installing SSL to support customer proxy servers. Customer proxy servers service the requests of its clients by forwarding requests to other servers. To install SSL to support customer proxy servers:
Install SSL on the Gateway machine. Use the same installation instructions as specified for Focalpoint 3.5.
Stop the Galileo SSL Service:
Right-click My Computer and choose Manage.
Open Services and Applications > Services.
Select the Galileo SSL Service and click STOP.
Enable proxy server support by adding the IP Address or DNS name of the proxy server in the SSLClientService.exe.config file. 
Navigate to the default install folder. For example, C:\Program Files\Galileo\SSL
Right-click the file and choose Open With.
Select Notepad.
Add the following lines in the <AppSettings> section with the information for the customer:
<add key="Proxy Server Address" value="customer proxy"/>
<add key="Proxy Server Port" value="customer proxy port"/>
Choose File > Save.
Restart the Galileo SSL Service:
Select the Galileo SSL Service in the Computer Management dialog box and click START.
Close the Computer Management dialog box.
Note: When using an HTTP proxy, please assure that the proxy idle timeout on port 443 is set to 3600 seconds or higher.


[bookmark: OLE_LINK1][bookmark: OLE_LINK2][bookmark: OLE_LINK3][bookmark: _Toc241309889]Uninstalling Galileo SSL
Every time a new SSL package is installed, the previous version is uninstalled. The option exists, however, to completely remove the SSL package. Following are instructions to completely uninstall Galileo SSL from a computer:
Note:	For a Silent Uninstall, see the Silent Uninstall section below these instructions.
Navigate to the Control Panel (typically from the Start menu, select Start > Settings > Control Panel. Review the help system for the OS to determine the correct procedure to display the Control Panel).
Double-click Add or Remove Programs.
Select Galileo SSL.
Click Change/Remove.
The following dialog box displays. Click Yes.

The Uninstall Complete dialog box displays. Click Finish.

[bookmark: _Toc241309890]
Silent Uninstall
An option exists for “silent” uninstall, and no further uninstall procedures are required. This applies to all applications except XML Select. XML Select users must use the previous manual uninstall instructions. To set the application for Silent Uninstall:
Close any supported products.
Open a command window and navigate to the SSL installation file (.exe) location.
Type in the name of the install executable followed by the parameters –s –a –us. For example, GalileoSSLClient_v01.00.0012.exe -s -a -us
The first parameter ‘s’ specifies that the package extraction is silent.
The second parameter ‘a’ specifies to start setup.exe. 
The third parameter ‘us’ specifies the type of uninstall the setup should run: 'us' is uninstall silent.
The third parameter can also be just ‘u’ to specify a standard uninstall procedure (not silent).
[bookmark: _Toc241309891]
Appendix A: SSL Client Configuration Parameters
Following is a reference table that specifies various parameters when installing and configuring the SSL Installation.
	Literal Key to use in .config file
	When used, the key specifies:
	Default, if not specified

	SSL (GDAS) Server

	SSL Server Address
	The PRODUCTION GDAS Server to use
	gdssl.galileo.com

	Copy SSL Server Address
	The COPY GDAS Server to use
	Gdssl-copy.galileo.com

	SSL Server Port
	The servers port to target
	443

	LCN Complex

	Configuration Server Address
	The PRODUCTION IPCS address to target
	57.8.81.13

	Copy Configuration Server Address
	The COPY  IPCS address to target. (Now redundant parameter. COPY GDAS server is targeted instead)
	

	Configuration Server Port
	The IPCS port to use
	5067

	Client IPC Port
	The primary port we listen on for IPC requests (now redundant parameter)
	

	Client IPCS Port
	The port we listen on for IPCS requests
	5067

	Copy IPCS Prepend String
	Prepending a zero to the existing Copy Client ID is required for Copy system access
	“0”

	Other Endpoints

	MQ Server
	The MQ Server IP address used for printing
	57.8.16.41

	MQ Printing Port
	The MQ Server IP port used for printing
	1414

	GIDS Server
	The GIDS Server IP address to use
	57.8.16.41

	GIDS Port
	The GIDS Server IP port to use
	1415

	GIDS Queuename Override
	The target GIDS queue to use if the automatic generation does not work (uses primary FP ClientID) (See the Configuring GIDS for Galileo SSL section regarding multiple queues).
	<not configured>

	TN3270 Server
	The TN3270 server to target
	57.8.81.14

	TN3270 Port
	The TN3270 server port to target
	5023

	PM Browser Server
	The HTTP server to send PM Browser requests to
	57.8.16.39

	PM Browser Server Port
	The HTTP server port to send PM Browser requests to
	80

	PM Browser Listen Port
	The port we listen on for PM Browser traffic
	8765

	GPM

	GPM Wakeup Interval
	The period in minutes between faked GPM wakeups
	4

	Server Mode GPM machine IP Addresses
	The IP addresses of known GPM machines to send wakeups to ONLY when using SSL Client Server Mode
	<not configured>

	Server Mode Local IP Address
	Use to override the detected local IP address of the machine ONLY when using SSL Client Server Mode
	<not configured>

	Proxy Server Configuration

	Proxy Server Address
	The IP address/dns name of a proxy server to use if required
	<not configured>

	Proxy Server Port
	The IP port of a proxy server to use if required
	<not configured>

	General Configuration

	Server Mode
	Enables SSL Client Server Mode. Traffic from local network machines will be accepted. To enable, set to “Enabled”.
	<not configured>

	Spoof Version 3
	Test config parameter. Do not use.
	False

	Disable Redirects
	Prevents automatic redirection to preferred GDAS SSL servers. To enable, set to “True”.
	False

	Keepalive Seconds
	The period in seconds between TCP/IP low level keepalives. May be tuned to avoid networking issues regarding lost connections.
	120

	Trace Level Override
	Changes the tracing level of the SSL Client. Values may be Critical, Error, Warning, Information, Verbose or All
	Warning



[bookmark: _Ref204399998][bookmark: _Ref204400000][bookmark: _Toc241309892]Appendix B: DNS/VIP Addresses
The DNS and VIP Addresses vary based on the location of the agency.
	Location
	DNS
	VIP
	Access

	Atlanta
	gdssl.galileo.com
	216.113.159.225
	Default

	
	gdssl-atl.galileo.com
	216.113.159.226
	Default

	
	sslfpemea.galileo.com
	216.113.159.227
	Default

	
	
	
	

	Denver
	gdssl.galileo.com
	12.17.227.30
	Backup

	
	gdssl-atl.galileo.com
	12.17.227.145
	Backup

	
	sslfpemea.galileo.com
	12.17.227.146
	Backup

	
	
	
	

	Langley
	gdssl.galileo.com
	194.24.254.201
	Backup

	
	gdssl-atl.galileo.com
	194.24.254.193
	Backup

	
	sslfpemea.galileo.com
	194.24.254.204
	Backup

	
	
	
	


[bookmark: _Toc241309893]Copy System Access
To direct a client ID to the Travelport copy system complex, add a leading "zero" to your client ID.  If your copy system client ID is wgal1000, use 0wgal1000 in your client to target the copy systems.  Copy system access is available in v1.7 and later of the SSL retro client.
For XML Select users who test against a Copy environment, use the following DNS:
DNS:	gdsslpp-atl.galileo.com
Galileo Desktop can connect to Production and non-prod system simultaneously using this feature.  Client IDs without the leading zero will connect to production, while those with the leading zero will connect to a non-production (Copy) server.
Galileo Print Manager does not yet work via Copy systems using the leading zero feature.  However, users that need to target the Copy system from GPM must make the following changes to the SSLClientService.exe.config file:
    <add key="SSL Server Address" value="gdsslpp-atl.galileo.com" />
Note: GPM can only connect to Production or non-production (Copy).  After this change is made, all GPM connections from this server will go to the Copy system.
[bookmark: _Toc241309894]
Add-ons Workaround
A Focalpoint/Desktop add-on is a feature, like Relay, Rapid Reprice, WebFares, Point and Click, ARNE, AutoServiceFee. These check the “Host=” statement in the WIN.INI file to validate what host is configured. Focalpoint/Desktop treats all Client IDs that start with “G” as Galileo and all others as Apollo, and sets this host= statement accordingly. 
The new SSL copy access requires that you prepend a zero in front of the Client ID so a Galileo Copy Client ID triggers the application to set the win.ini as host=Apollo. The workaround for copy applies to a Galileo Copy Client ID. You need to configure with the zero, then change the host in win.ini back to host=Galileo.
To begin, open the win.ini file, and make the following change:
Before:
[Focalpoint]
SWDIR=C:\fp\swdir\
DATADIR=C:\fp\datadir\
MACHINEDIR=C:\fp\machine\
Host=Apollo
After:
[Focalpoint]
SWDIR=C:\fp\swdir\
DATADIR=C:\fp\datadir\
MACHINEDIR=C:\fp\machine\
Host=Galileo

[bookmark: _Toc241309895]Transient DNS Changes
The DNS to which you are assigned will remain the same (see the Default labels in the Access column in the DNS/VIP table), unless a problem arises and all users on that DNS are moved to another DNS. This migration is transparent, except that if you ping or trace your assigned DNS, the VIP will display the new system to which traffic is going. Upon completion of the fix, you will be switched back to your original VIP.
[bookmark: _Toc241309896]
Appendix C: Troubleshooting
[bookmark: _Toc241309897]64-BIT OS Support
64-bit operating systems are now supported in SSL Client version 1.7 and above. However, there are several installation modifications required in order for it to work properly:
[bookmark: _Toc241309898]Installation
When installing the SSL Client, the install directory is \Program Files. After installation, 
Navigate to C:\Program Files directory (or the default program files directory on your 64-bit machine).
Copy the Galileo International folder.
Navigate to C:\Program Files (x86).
Paste the Galileo International folder into the C:\Program Files (x86) directory.
[bookmark: _Toc241309899]ODBC Support
In the Windows 64-Bit OS, when creating an ODBC connection to the GIDS database, the default 64 Bit ODBC does not work. To add GIDS database configuration, set your ODBC configuration to access C:\Windows\SYSWOW64\odbcad32.exe.
[bookmark: _Toc241309900]Double-NIC
Double-NICs are supported in both 32-bit and 64-bit operating systems.
[bookmark: _Toc241309901]
Telnet
Being able to telnet from your OS is a pre-requisite as a download from the SSL server. To test whether you can telnet from your OS, you must be able to launch a telnet application. In Windows XP, you can perform this from a DOS prompt. In Windows Vista, a 3rd-party application is required. To test via telnet whether you can connect to the SSL VIP:
Launch your telnet application.
Enter the following commands (below). If you can connect, you will receive a blank screen. Press the Enter key to drop the connection.
telnet gdssl-atl.galileo.com 443
Note: You may receive the note:
Could not open connection to the host, on port 443: Connect failed.
This note indicates there is a connectivity issue between the workstation and the Galileo SSL farm. This should be investigated by the agency network personnel, and is likely a firewall rule issue. See the instructions on firewall rules and configuration for your installation type.
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