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[bookmark: _Toc259794295]Introduction
SSL (Secure Sockets Layer) is a commonly used protocol for managing the security of a message transmission on the Internet. Galileo SSL enables agencies to use their existing computers and print servers to access the Apollo® and Galileo® Computer Reservation Systems (CRS) over the public Internet via an encrypted, secured connection.
This guide demonstrates how to determine your Client ID, your current SSL Client version, and, how to install the latest version of the SSL Client. The minimum version of SSL supported is Version 12 (01.00.0012.00).
[bookmark: _Toc333998181][bookmark: _Toc147566989][bookmark: _Toc165270993][bookmark: _Toc259794296]Minimum Software Requirements
The following requirements are needed for the SSL installation:
A supported product.
Internet access.
Allow SSL service on port 443 through Firewall or other customer infrastructure.
Set idle timeouts on port 443 connections at 3600 seconds or higher.
If using an HTTP proxy, ensure the proxy idle timeout on port 443 is set to 3600 seconds or higher.
Windows 2000 Professional®, Windows XP® (all versions), Windows Vista® (all versions), and Windows 7® (all versions). 
Note: It is possible to support a Legacy OS in Gateway Mode.
Microsoft .NET Framework® version 2.0 (x86) or later needs to be installed. If .NET Framework is not present, the installation process automatically downloads this software from Microsoft and completes this portion of the installation.
Microsoft Installer 3.1 v2 (KB893803)
If Microsoft XP is installed, Microsoft Installer 3.1 v2 or later must be installed.
Notes: 
The installer must have Administrative rights
Install SSL connection under the supervision of someone with a working knowledge of your office hardware.
ISP must provide minimum bandwidth as legacy leased-line providers. Ensure you monitor ISP connection utilization and increase the bandwidth when utilization grows close to saturation. Most agencies discover that the bandwidth to support GDS access is extremely low.
If you install the SSL client, create new connection profiles, then uninstall or reinstall the latest version, the SSL client, you will lose the connection profiles. 
To maintain your connection profiles, manually add the connection profiles, and then install the SSL Client.
If you meet all the following conditions, the Client ID will need to be re-added:
The machine has Multiple Connections
A Client ID was added after a previous SSL Client installation
A new version of the SSL Client is installed
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Determining your Client ID
Determining your Client ID is important when discussing any problems or issues with the support desk. Additionally, as a precaution, for any existing SSL Client version, the Client ID should be captured before installing a new version. 
For step 3 below, write down all the Client ID information, or capture the information in a screen shot.
Note: If you have Multiple Connections, and a Client ID was added after the initial SSL Client install, installing the latest version removes any Client IDs added after the first SSL install. See the Configuring Multiple Connections topic. 
To determine the Client ID:
Open the Control Panel on your computer. For example in Windows XP, choose 
Start > Settings > Control Panel.

Double-click Galileo TCP/IP to display the Host/<software> TCP/IP Configuration dialog box.

If multiple connections exist, more than one connection name is listed. Review the Client ID column and write down the Client ID (g#### or a####) number.
[image: Client_ID_Determination_3]
Note: This information can also be captured via the Print Screen option:
Press Ctrl+PrtScn on the keyboard.
Launch the Windows Paint application (typically Start > Programs > Accessories > Paint.
Choose Edit > Paste.
Choose File > Save As.
Select a location and choose Save.
Click OK to close the dialog box.
Verify the Client ID after following the directions in the Installing the Latest Version of the SSL Client section. See the topic Verifying and Reinstating the Client ID and Configuring Multiple Connections.
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Determining the Current SSL Client Version
To begin the versioning process for the SSL client, it is important to determine the current version of the SSL Client on the machine. To determine the version:
Navigate to the machine’s desktop.
Right-click My Computer to display the drop-down menu and select Manage. The Computer Management dialog box displays.
[image: Determine_Version_1]
Click the + next to Services and Applications in the Computer Management dialog box.
[image: Determine_Version_1]
Click the Services option to display the list of Services on the machine.
[image: Determine_Version_1]
Right-click the Galileo SSL Tunnel service and select Properties.
[image: Determine_Version_2]

Review the SSL Version Number in the Galileo SSL Tunnel Properties dialog box:
If the Description indicates Galileo SSL Client Service 01.00.0012.00 or greater, go to step 7. A support agent can now assist you with any issue.
If the Description indicates Galileo SSL Client Service 01.00.0011.00 or less, go to step 7, then follow the instructions in Installing the Latest Version of the SSL Client.
[image: Determine_Version_3]
Click the Cancel button, and choose File > Exit in the Computer Management dialog box.
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Installing the Latest Version of the SSL Client
If your Galileo SSL Client Service is version 01.00.0011.00 or less, a new version of the SSL client is required. 
Note: If Multiple Connections exist, and a Client ID was added after the previous Galileo SSL Client installation, the Client ID must be re-added after installing the latest version of the SSL Client. See the Configuring Multiple Connections topic.
To install the latest SSL Version:
Go to the following URL in your internet browser:
http://support.travelport.com/SGC/APS/softlib/GalileoDesktopSSL.htm 

Scroll to the bottom of the page to display the Software Download Form.

Complete the form and click Submit:
First Name: Enter your first name.
Last name: Enter your last name.
Company: Enter the name of the company that has the SSL client installed.
Address: Enter the company address.
City: Enter the name of the City where the company is located.
State or Province: Enter the name of the State or Province where the company is located.
Zip or Postal Code: Enter the Zip Code or Postal Code associated with the Company address.
Pseudo City Code: Enter the PCC of the company or agency.
Host System: Select the Apollo, Galileo, or Both radio button based on the company or agency access.
Software to be installed by: Select either Company Employee or Consultant from the drop-down list.
Desktop Software Being Used: Select the software being used at the company or agency location.
Using On PCs which formerly connected using: Select the appropriate completion to the statement from the dropdown menu.
Select the Agreement check-box.

Click Submit to display the Galileo SSL Download page.
Click the Download link.

Click Save in the File Download dialog box.


Navigate to the location to save the file. For example, click Desktop.

Click Save. The application installation download (.exe) file is saved to your machine.
Note: The .exe file that is saved to the desktop can be used to install this version of the Galileo SSL Client on other machines.

Click Run in the Download Complete dialog box. The application will begin to install.

Click Run in the Internet Explorer – Security Warning dialog box (or any associated dialog box that displays, based on your version of your internet browser software and associated operating system).

Click Yes in the Galileo SSL Client Install dialog box to uninstall the previous version of the SSL Client.

The Progress dialog box displays the progress of the uninstall process.

Click Next in the Galileo SSL Install Wizard.
[image: Download_Install_9]
Read the Terms and Conditions and select the “I acknowledge…” radio button.

Click Next.

Click Finish.
Verify that Version 12 is installed by repeating Steps 1-6 in the Determining Current Version section.
[image: Download_Install_12_Success]
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Verifying and Reinstating the Client ID
Anytime the product is versioned, all configuration settings remain the same, except the IP address. 
If a downline workstation is connected to a Gateway Server, the downline workstation will not lose the Client ID after installing or versioning the SSL Client.
However, the Gateway Server will need to reinstate a line in the configuration file, and the IP Address will need to be verified. See Re-enabling the Galileo SSL Tunnel for Gateway Mode.
For more information about Gateway Mode, see the SSL Connection Install Guide.
To verify the Client ID after versioning the Galileo SSL client to version 12 or above, perform the following steps:
Choose Start > Settings > Control Panel > Galileo TCP/IP to display the Host/Galileo Desktop TCP/IP Configuration dialog box.
[image: Client_ID_Determination_3]
Review the Client ID column to verify the Client ID is the same as determined in the Determining your Client ID section.
If the Client ID is the same, the versioning process is complete.
If Multiple Connections exist, and a Client ID was added after the initial Galileo SSL Client installation, the Client ID will need to be re-added. See the topic Configuring Multiple Connections.
If the Client ID is missing, and it was not added after the first Galileo SSL Client installation, follow the steps in the Re-enabling the Galileo SSL Tunnel for Gateway Mode, and then follow the steps in Reinstating the Client ID.
[bookmark: _Toc259794301]
Re-enabling the Galileo SSL Tunnel for Gateway Mode
If the SSL version is versioned up on a machine running in Gateway mode, the “server mode” must be re-enabled. To re-enable machines operating as a Gateway:
Open Windows Explorer and navigate to C:\Program Files\Galileo\SSL
Right-click the SSL.ClientService.exe.config and choose Open With > Notepad.
[image: Gateway_mode_prior_versioning_1]
Add the text:
<add key=”Server Mode” value=”enabled”/> after the line
<add key= “Trace Level Override” value=”Warning” />
[image: Gateway_mode_prior_versioning_2]
Choose File > Save. A warning dialog displays. Click Yes.
[image: Verify_ClientID_3]
Right-click My Computer and choose Manage to display the Computer Management dialog box.
[image: Verify_ClientID_4]
Double-click Services and Applications to display a list of services, 
[image: Verify_ClientID_5]
Select Galileo SSL Tunnel.
Click the Restart Service button at the top of the Computer Management dialog box.
[image: Verify_ClientID_7]
The Service Control dialog box displays to stop and restart the Galileo SSL Tunnel.
[image: Verify_ClientID_8]
Choose File > Exit.
[image: Verify_ClientID_9]
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Reinstating the Client ID
To reinstate the ClientID after restarting the re-enabling the Galileo SSL Tunnel:
Choose Start > Run.
[image: Verify_ClientID_10]
Enter CMD in the Open field to display the Command Prompt.
[image: Verify_ClientID_11]
Enter cd \ at the c:\>… line to revert the line to c:\>
Enter ipconfig
[image: Verify_ClientID_12]
Find the IP Address line and write down the associated IP Address.
[image: Verify_ClientID_13]

Click the [image: Verify_ClientID_23] icon and choose Close.
[image: Verify_ClientID_14]
Open the Control Panel. For example, on Windows XP, choose Start > Settings > Control Panel. 
[image: Verify_ClientID_15]
Double-click the Galileo TCP/IP option.
[image: Verify_ClientID_16]
Select the connection name (default is “MyConnection”) and click Edit.
[image: Verify_ClientID_21]

Verify the Client Identifier. If blank, enter your Client ID.
[image: Verify_ClientID_19]
Select either Standard Windows or Apollo/Galileo Mapped in the Keyboard Mode area.
Select the Use Fixed Configuration Server Addresses button.
Enter the IP Address copied from Step 5 in the Primary IPCS Address and Secondary IPCS Address fields.
Click the Force Download check box.
Click OK. The Keyboard Mode warning box displays.
[image: Verify_ClientID_20]
Click OK to display the Host/<product name> TCP/P Configuration dialog box.
[image: Verify_ClientID_24]
Click OK.
Choose File > Close in the Control Panel.
[image: Verify_ClientID_22]

[bookmark: _Toc259794303]Configuring Multiple Connections
This section covers instructions for the following situation:
If multiple connections exist
If one or more Client IDs are configured for the Galileo software prior to the initial Galileo SSL installation
If one or more of the Client IDs was added after the first installation of the Galileo SSL Client
The Client IDs added after the initial Galileo SSL installation need to be re-added after the latest version of the Galileo SSL Client is installed.
For the purposes of this example, assume that two Client IDs existed before installing the initial SSL Client version. For this example, assume two Galileo Client IDs were configured for Galileo Desktop and Galileo SSL Client v01.00.0010 was initially installed.
[image: Mult_connect_1]
After installing the initial Galileo SSL Client (version 01.00.0010), a new Client ID is added (G3xxxxx).
[image: Mult_connect_3]
When the latest version of the Galileo SSL Client is installed (for this example, assume version 01.00.0012), the Client ID data added after the initial Galileo SSL Client installation (version 01.00.0010) is removed from the TCP/IP Configuration.
[image: Mult_connect_1]
See that the MyConnection3 is missing.
To re-add the Client ID(s)
Open the Control Panel. For example, on Windows XP, choose Start > Settings > Control Panel. 
[image: Verify_ClientID_15]
Double-click the Galileo TCP/IP option.
[image: Verify_ClientID_16]
Click New in the Host/<software> TCP/IP configuration dialog box.
[image: Mult_connect_4]

In the Connection dialog box, enter the following:
Enter the connection name in the Connection Name field.
Enter the Client ID (captured from Determining your Client ID).
Select either Standard Windows or Apollo/Galileo Mapped in the Keyboard Mode area.
Select the Use Fixed Configuration Server Addresses button.
Enter 127.0.0.1 in the Primary IPCS Address and Secondary IPCS Address fields.
Click the Force Download check box.
Click OK.
[image: Mult_connect_5]
Click OK in the Keyboard Mode warning box.
[image: Mult_connect_6]
The Host/<software> TCP/IP Configuration box displays the added Client ID.
[image: Mult_connect_7]
Click OK.
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Support
For further support contact your local Galileo Helpdesk to help with any installation or troubleshooting issues.
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