Galileo Desktop - Unable to get machinedir from win.ini error
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Galileo Desktop - Unable to get machinedir from win.ini error

Galileo Desktop -
Unable to get machinedir from win.ini, is Focalpoint installed properly?

Galileo USA – Advanced Product Support Knowledge Base
Galileo Desktop Control Panel Error "Unable to get machinedir from win.ini, is Focalpoint installed properly?"
Created by ASM: Kelly Smith
Modified on: September 26, 2007
Document Type: [_] Internal (Company Confidential) [X] Internal or External

APPLIES TO:

Windows Vista (all versions)
Galileo Desktop (all versions)

OVERVIEW:

Galileo Desktop does fails to connect to the Apollo or Galileo host system and when attempts are made to edit the Galileo TCP/IP applet in Windows Control Panel, a "Unable to get machinedir from win.ini, is Focalpoint installed properly?" error appears.

DESCRIBE ISSUE:

There are several related symptoms.

  • When you attempt to use the Windows Control Panel Galileo TCP/IP applet you see the following error "Unable to get machinedir from win.ini, is Focalpoint installed properly?"

You may also experience the following

  • No request for a username and password
  • A "Server Busy, Retry or ..." dialog box appears.
  • Repeated clicking on Server Busy or Retry will eventually take you to a normal application screen, but the status bar will show "Ctrl-R" to reset keyboard.
  • You see "Failed to open connection"
CAUSE:

On rare occasions, Windows Vista will attempt to use the wrong WIN.INI file; attempting to open the WIN.INI file in the C:\Users\User_name\AppData\Local\VirtualStore\Windows folder vs.. the file in the C:\Windows folder. The WIN.INI file in the "virtualization folder" should not be used.

SOLUTION:

The solution is to prevent Windows from reading the wrong initialization file.

  • Make sure you are logged into Windows using an account with administrator privileges.
  • Click Exit to a CMD prompt by clicking the Start button, typing CMD and touching the enter key.
  • Type "set user" and make a note of the name shown after the USERNAME= line in the response.
  • Change directories to the :\Users\User_name\AppData\Local\VirtualStore\Windows folder by typing
    "CD AppData\Local\VirtualStore\Windows" (without the quotes) and touching the enter key.
  • The CMD prompt should change to
    C:\Users\User_name\AppData\Local\VirtualStore\Windows> where the User_name is most the name of the person logged into Windows.
  • Type REN WIN.INI WIN.OLD and enter
  • Type Exit and enter to exit the CMD window.
  • Click Start, type "fpcpl2app.cpl" (without the quotes) and enter.

The "Unable to get machinedir ..." error should no longer appear and the Galileo TCP/IP applet (figure 2 below) should appear. Make the appropriate changes or additions to this applet and save the settings. When Galileo Desktop is started, enter a name in the splash screen then click "Start Galileo Desktop". The next screen should be a request for a "User name" and password.

Related articles:

For more information, see Microsoft's Knowledge Base Article #927387 at http://support.microsoft.com/kb/927387

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