Galileo Desktop - Lock Up Issue
Galileo USA – Advanced Product Support Knowledge Base
Galileo Desktop - Application Locks Up, Ready Status Disappears
Created by ASM: Gordon McHenry / Kelly Smith
Modified on: July 11, 2008
Document Type: [_] Internal (Company Confidential) [X] Internal or External
APPLIES TO:
Galileo Desktop Version v1.01
Galileo Desktop Version v1.5 (not used in the U.S. or Canada)
Galileo Desktop Version v2.0
Note - Galileo Desktop v2.1 includes this patch. Travelport's recommendation is that customers encountering this problem consider upgrading to Galileo Desktop v2.1 rather than applying this patch. For more information about Galileo Desktop v2.1 and caveats, click here.
Note - Focalpoint v3.5 does not exhibit this behavior.
OVERVIEW:
Galileo Desktop users may experience a lock up of their system due to a connection break. This can occur with any type of connection. More commonly this issue is being identified for customers using ISP connections with SSL or Customer Managed VPN.
Connection types which may experience this problem include: Customer Managed VPN, SSL Connection, Wingate, and Leased Lines.
DESCRIBE ISSUE:
While working with Galileo Desktop, if no entry is made for a period of time, the connection status shown in the bottom left hand corner of the Galileo Desktop application will simply disappear. The screen shots below show the normal "Ready" status. If experiencing the "lock up issue" and there is no "Ready" status, upgrading to Galileo Desktop v2.1 or applying this "fix" may address the problem.
Once the "Ready" status disappears, attempts to use Galileo Desktop will results in errors such as "Host Connection Lost", "No Host Connection", etc.
While rebooting the computer or simply restarting Galileo Desktop may fix the problem for a few minutes, doing so is not a long term fix.


CAUSE:
Some internet service providers (ISP) do forward the "keep-alive" which is sent by Galileo Desktop over the VPN connection..
SOLUTION:
- Reboot the work stations and in most cases, this will repair the connection.
- Upgrade to Galileo Desktop v2.1
- Install the Desktop patch which will resolve connection breaks in the future.
In the event the customer is unsure if the patch has already been applied, the user can install the patch again. If it has already been applied, a message will display indicating the patch has been applied. The user can then abort or cancel the patch installation.
Download:
To download the Galileo Desktop "lock up issue" patch, click here.
While you may "run" this patch by simply clicking the link, we suggest you right click the link above, then select "Save Target As" or "Save To Download Folder" and save the file to your local computer or a network drive. Then run the "fix" from the saved location.
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